Better "quickstart" guideance anywhere?

Support

Are there any instructions for how to get started with Factor that actually cover the numerous steps that clearly need to be undertaken before npx create-factor-app ?

I've got as far as firguing out that you need to install nodejs, npm and npx, but even with those 3 it still errors out. And where am I meant to be typing the above command? Terminal? Powershell? Node?

Fellow newbie here, feel your pain, i am using VS code on windows. I am using a bash shell . I ran the commands there.
I had to update my node. Install node 12 + or higher, its written it the manual instructions page that its required.

I am stuck on building the env, on the first try i got a choice of 3 themes,I chose one and then it crashed, now i can seem to get the server up.

Goodluck!

Ya, this is standard Node development which is built around your terminal.

What's the error you guys are getting? That may be a bug; if not, we can clearly improve the error reporting.

While we wait for egsdgdsgdsgs-4Jk to reply, I can tell you after i run factor dev, its starts building the app , it stays at emitting 95% for a very loong time, the first time i got in created an Admin user and pass and got a choice of 3 themes and chose one(not the default) and it crashed and asked me to run factor dev manually.

I have dont it 3 times now and after staying at 95% for a while it crashes without getting to login. just keeps asking me to run factor dev manually

Ya that's definitely not supposed to happen! What's the error you're getting in the terminal?


√ Ready at http://localhost:3000                                                           19:40:19

 ERROR  Server Rendering Error                                                             19:40:28  
 url:/

 Cannot read property 'currentRoute' of undefined
 
 and then it goes on the list , here are a few lines :
  at currentRoute (webpack:.../node_modules/@factor/app/router.ts?:240:23)
  at preFetchPost (webpack:///:.../node_modules/@factor/api/prefetch.ts?:18:96)
  at callback (webpack:///:.../node_modules/@factor/post/index.ts?:56:99)
  at callback (webpack:///:.../node_modules/@factor/api/hooks.ts?:164:13)
  at applyFilters (webpack:///C:/:.../node_modules/@factor/api/hooks.ts?:100:28)
	
	Also look at my package json:
	{
  "name": "newproject",
  "version": "1.0.0",
  "description": "",
  "main": "src/index",
  "private": true,
  "dependencies": {
    "@factor/core": "^1.0.0",
    "@factor/plugin-notify": "^1.0.0",
    "@factor/plugin-seo": "^1.0.0",
    "@factor/plugin-sitemap": "^1.0.0",
    "@factor/plugin-contact-form": "^1.0.0",
    "@factor/plugin-storage-s3": "^1.0.0",
    "@factor/theme-ultra": "^1.8.14"
  },
  "factor": {
    "app": {},
    "admins": [
      "**************"
    ],
    "load": [
      "app",
      "server"
    ]
  }
}

Looks like you're on Windows, that might be related.. I'll check it out.

This is the error message i am getting below, i have to agree with
@egsdgdsgdsgs-4Jk there is no effort to inform the user on how to really get started, i downloaded Node JS V12 after that what am i to do? the documentation is not explicit or consise, the video started from intermediate level
it will be nice for us to have a step by step plan on what to install on the machine and how to start the process towards, typing npx create-factor-app

8